nefu 561 方块计算(DFS)

网友投稿 306 2022-08-27

nefu 561 方块计算(DFS)

description

有一间长方形的房子,地上铺了红色、黑色两种颜色的正方形瓷砖。你站在其中一块黑色的瓷砖上,只能向相邻的黑色瓷砖移动。请写一个程序,计算你总共能够到达多少块黑色的瓷砖。

input

输入有多组。每组的第一行是两个整数W 和H,分别表示x 方向和y 方向瓷砖的数量。W 和H 都不超过20。在接下来的H 行中,每行包括W 个字符。
 每个字符表示一块瓷砖的颜色,规则如下:
 1)‘.’:黑色的瓷砖;
 2)‘#’:白色的瓷砖;
 3)‘@’:黑色的瓷砖,并且你站在这块瓷砖上。该字符在每个数据集合中唯一出现一次。

output

输出你总共能够达到的方块数。

sample_input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

sample_output

45
59
6
13
题解:注意:凡是走过的瓷砖不能被重复走过,可以通过每走一块瓷砖就将它标记,保证不重复计算任何瓷砖。
AC代码:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
const int dx[]={1,-1,0,0};
const int dy[]={0,0,1,-1};
int n,m;
char a[100][100];
void dfs(int x,int y)
{
int tx,ty,i;
a[x][y]='$'; //将‘.’用‘$’代替,然后统计‘$’的个数
for(int i=0;i<4;i++)
{
tx=dx[i]+x;
ty=dy[i]+y;
if(tx>=0&&tx<n&&ty>=0&&ty<m&&a[tx][ty]=='.')
{
dfs(tx,ty);
}
}
}
int main()
{
int i,j,count,x,y;
while(~scanf("%d%d%*c",&m,&n)&&m+n!=0)
{
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
{
for(j=0;j<m;j++)
{
scanf("%c",&a[i][j]);
if(a[i][j]=='@')
{
x=i;
y=j;
}
}
getchar();
}
dfs(x,y);
count=0;
for(i=0;i<n;i++)
for(j=0;j<m;j++)
if(a[i][j]=='$')
count++;
printf("%d\n",count);
}
return 0;
}------------------------------------#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

int N,M;
char Map[35][35];

int DFS(int x,int y)
{
int d = 0;
if(x < 0 || x >= N || y < 0 || y >= M || Map[x][y] == '#')
return 0; //返回,递归边界
if(Map[x][y] == '.' || Map[x][y] == '@')
{
d = 1; //标记,避免重复搜索
Map[x][y] = '#';
}
return DFS(x+1,y) + DFS(x,y+1) + DFS(x-1,y) + DFS(x,y-1) + d;
}

int main()
{
while(~scanf("%d%d",&M,&N) && (N||M))
{
int ans = 0;
for(int i = 0; i < N; ++i)
scanf("%s",Map[i]);

for(int i = 0; i < N; ++i)
for(int j = 0; j < M; ++j)
if(Map[i][j] == '@')
ans = DFS(i,j);

printf("%d\n",ans);
}

return 0;
}









版权声明:本文内容由网络用户投稿,版权归原作者所有,本站不拥有其著作权,亦不承担相应法律责任。如果您发现本站中有涉嫌抄袭或描述失实的内容,请联系我们jiasou666@gmail.com 处理,核实后本网站将在24小时内删除侵权内容。

上一篇:L3-3. 社交集群
下一篇:湖南修路(最小生成树prim)
相关文章

 发表评论

暂时没有评论,来抢沙发吧~